分析家公式網,最大的股票公式,股票軟件下載站 用戶登錄  |  用戶注冊
波神凱線入場出場 詳細用法說明(視頻)
  • 軟件大小:15.0 KB
  • 推薦星級:
  • 更新時間:2009-05-19 15:34:33
  • 軟件類別: 國產軟件 / 飛狐股票公式
  • 軟件語言:簡體中文
  • 授權方式: 解密版
  • 聯系方式:暫無聯系方式
  • 官方主頁: Home Page
  • 點擊大圖:  【一鍵轉帖到論壇】
  • 插件情況:
  • 運行環境:Win9X/Win2000/WinXP/Win2003/
  • 相關Tags:股票公式 股票軟件
  • (14)47%
    (16)53%

軟件簡介

{波神凱線入場出場運用視頻
波神入場與出場視頻演示地址:
http://www.tudou.com/programs/view/jDS9rSIovyE/ }

{波浪與波神}

{----------------------波神凱線源碼----------------------------------}
INPUT:最近天(20,1,360);

當前月:=FRACPART(ROUND(當前日期/100)/100)*100;
月:=MONTH;日:=DAY;
VERTLINE(月=1 AND (  日=25)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=3 AND (  日=20)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=5 AND (  日=12)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=6 AND (日=14 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=7 AND ( 日=19 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=8 AND ( 日=6 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=9 AND ( 日=18 )),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=10 AND ( 日=31)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=11 AND ( 日=28)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=12 AND ( 日=31)),COLORFFFFFF,LINEDASHDOT;
VERTLINE(月=1 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=2 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=3 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=4 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=5 AND ( 日=6 OR 日=15 OR 日=21 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=6 AND ( 日=6  OR 日=21)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=7 AND ( 日=8 OR 日=15  OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=8 AND ( 日=8  OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=9 AND ( 日=8 OR 日=15  OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=10 AND ( 日=8 OR 日=15 OR 日=23 )),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=11 AND ( 日=8 OR 日=15 OR 日=23)),COLORAAAAAA,LINEDASHDOT;
VERTLINE(月=12 AND ( 日=8 OR 日=15 OR 日=23 )),COLORAAAAAA,LINEDASHDOT;

N:=if(sysparam(1)=datacount,最近天,datacount-sysparam(1));
HH:=HHV(HIGH,N);
LL:=LLV(LOW,N);
VN:=N;
{LAST1:=DATACOUNT;}
IF VN>DATACOUNT THEN
VN:=DATACOUNT+1;
FOR I=DATACOUNT DOWNTO DATACOUNT-VN+1 DO BEGIN
    HH[I]:=HH[DATACOUNT];
    LL[I]:=LL[DATACOUNT];
END;
TMP:=SETLBOUND(hh,DATACOUNT-VN+1);
TMP:=SETLBOUND(ll,DATACOUNT-VN+1);
階段高:HH,LINETHICK2,color0000FF;階段低:LL,LINETHICK2,color00FF00;
中線:(HH+LL)/2,linethick0;
KKH:=BARSLAST(H=HH);
KKL:=BARSLAST(L=LL);
N低日:=STRTONUM(NUMTOSTR(REF(DATE,KKL),0)),LINETHICK;
N高日:=STRTONUM(NUMTOSTR(REF(DATE,KKH),0)),LINETHICK;
多空:IF(N低日>N高日,2,1),LINETHICK0;
多空天:IF(N低日<N高日,kkl,kkh),LINETHICK0;

DATE1:=IF(多空=1,N低日,N高日);{}
hh0:=ref(h,BARSLAST(DATE1=DATE));
ll0:=ref(l,BARSLAST(DATE1=DATE));
H1:=STRTONUM(NUMTOSTR(Hh0,3)),POINTDOT;
L1:=STRTONUM(NUMTOSTR(Ll0,3)),POINTDOT;
     PARTLINE(1,H1),,POINTDOT,linethick0;
     PARTLINE(1,L1),,POINTDOT,linethick0;
LL:=H1 - L1;
VERTLINE(DATE=DATE1),COLORFFAAAA,,LINETHICK2;
DRAWTEXT(DATE=DATE1,SYSPARAM(4)*0.95,'起\n \n始\n \n線'),COLORFFFFFF;
起始至今天:BARSLAST(DATE1=DATE),COLORFFFF00,LINETHICK0;
漲幅:(C-REF(C,起始至今天))/REF(C,起始至今天)*100,COLORFFDDDD,LINETHICK0;
IF 多空=1 THEN BEGIN
     {看多}
開門線:     PARTLINE(DATE>=N低日,LL*1.50801 + L1),LINETHICK1,COLOREE99FF;;
     PARTLINE(DATE>=N低日,LL*2.00001 + L1),COLOR9999FF,LINEDOT;
多2線:     PARTLINE(DATE>=N低日,LL*2.40001 + L1),COLORFFFF99,linethick1;
     PARTLINE(DATE>=N低日,LL*3.05001 + L1),COLOR99FF99,LINEDOT;
     PARTLINE(DATE>=N低日,LL*3.75001 + L1),COLORFF9999,LINEDOT;
多5線:     PARTLINE(DATE>=N低日,LL*4.15001 + L1),COLORMAGENTA,linethick2,LINEDOT;
     PARTLINE(DATE>=N低日,LL*4.80001 + L1),COLORRED,LINEDOT;
多7線:     PARTLINE(DATE>=N低日,LL*5.50001 + L1),COLORCYAN,linethick2;
     PARTLINE(DATE>=N低日,LL*6.10001 + L1),COLORGREEN,LINEDOT;
     PARTLINE(DATE>=N低日,LL*6.90001 + L1),LINETHICK1,COLORRED;

     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*1.50801+0.002,NUMTOSTR(L1+LL*1.50801,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*2.00001+0.002,NUMTOSTR(L1+LL*2.00001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*2.40001+0.002,'NO.2 '+NUMTOSTR(L1+LL*2.40001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*3.05001+0.002,NUMTOSTR(L1+LL*3.05001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*3.75001+0.002,NUMTOSTR(L1+LL*3.75001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*4.15001+0.002,'NO.5 '+NUMTOSTR(L1+LL*4.15001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*4.80001+0.002,NUMTOSTR(L1+LL*4.80001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*5.50001+0.002,'NO.7 '+NUMTOSTR(L1+LL*5.50001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*6.10001+0.002,NUMTOSTR(L1+LL*6.10001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,L1+LL*6.90001+0.002,NUMTOSTR(L1+LL*6.90001,2)),COLORAAAAAA,ALIGN2; 
     DRAWTEXT(DATE=DATE1,LL*1.50801 + L1+0.002,'多開門'),colorred;
     DRAWTEXT(DATE=DATE1,LL*6.90001 + L1+0.002,'多關門'),colorred;
     END;
ELSE   BEGIN
{看空}
空開門線:     PARTLINE(DATE>=N高日,H1-LL*1.50801),LINETHICK1,COLOREE99FF;
     PARTLINE(DATE>=N高日,H1-LL*2.00001),COLOR9999FF,LINEDOT;
空2線:     PARTLINE(DATE>=N高日,H1-LL*2.40001),COLORFFFF99;
     PARTLINE(DATE>=N高日,H1-LL*3.05001),COLOR99FF99,LINEDOT;
     PARTLINE(DATE>=N高日,H1-LL*3.75001),COLORFF9999,LINEDOT;
空5線:     PARTLINE(DATE>=N高日,H1-LL*4.15001),COLORMAGENTA;
     PARTLINE(DATE>=N高日,H1-LL*4.80001),COLORRED,LINEDOT;
空7線:     PARTLINE(DATE>=N高日,H1-LL*5.50001),COLORCYAN;
     PARTLINE(DATE>=N高日,H1-LL*6.10001),COLORGREEN,LINEDOT;
空關門線:     PARTLINE(DATE>=N高日,H1-LL*6.90001),LINETHICK1,COLORRED;
     DRAWTEXT(DATE=DATE1,H1-LL*1.50801+0.002,'空開門'),color3333FF;
     DRAWTEXT(DATE=DATE1,H1-LL*6.90001+0.002,'空關門'),color3333FF;

     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*1.50801+0.002,NUMTOSTR(H1-LL*1.50801,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*2.00001+0.002,NUMTOSTR(H1-LL*2.00001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*2.40001+0.002,'NO.2 '+NUMTOSTR(H1-LL*2.40001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*3.05001+0.002,NUMTOSTR(H1-LL*3.05001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*3.75001+0.002,NUMTOSTR(H1-LL*3.75001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*4.15001+0.002,'NO.5 '+NUMTOSTR(H1-LL*4.15001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*4.80001+0.002,NUMTOSTR(H1-LL*4.80001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*5.50001+0.002,'NO.7 '+NUMTOSTR(H1-LL*5.50001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*6.10001+0.002,NUMTOSTR(H1-LL*6.10001,2)),COLORAAAAAA,ALIGN2;
     DRAWTEXT(SYSPARAM(3)=BARPOS,H1-LL*6.90001+0.002,NUMTOSTR(H1-LL*6.90001,2)),COLORAAAAAA,ALIGN2;
END;
高年:=ref(YEAR,BARSLAST(date=N高日));
高月:=ref(MONTH,BARSLAST(date=N高日));
高日:=ref(DAY,BARSLAST(date=N高日));
低年:=ref(YEAR,BARSLAST(date=N低日));
低月:=ref(MONTH,BARSLAST(date=N低日));
低日:=ref(DAY,BARSLAST(date=N低日));
DRAWTEXT(SYSPARAM(2)=BARPOS,H1,'最近'+NUMTOSTR(最近天,0)+'天最高價日期:'+NUMTOSTR(高年,0)+'年'+NUMTOSTR(高月,0)+'月'+NUMTOSTR(高日,0)+'日'+'\n \n'
+'最近'+NUMTOSTR(最近天,0)+'天最低價日期:'+NUMTOSTR(低年,0)+'年'+NUMTOSTR(低月,0)+'月'+NUMTOSTR(低日,0)+'日'),COLORFFAAAA,ALIGN4;

DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='1',c,NUMTOSTR(當前月,0)+'月轉折日:6、15、21、*25\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='2',c,NUMTOSTR(當前月,0)+'月轉折日:6、15、21\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='3',c,NUMTOSTR(當前月,0)+'月轉折日:6、15、*20、21\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='4',c,NUMTOSTR(當前月,0)+'月轉折日:6、15、21\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='5',c,NUMTOSTR(當前月,0)+'月轉折日:6、*1 2、15、21\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='6',c,NUMTOSTR(當前月,0)+'月轉折日:6、*1 4、21\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='7',c,NUMTOSTR(當前月,0)+'月轉折日:8、15、*1 9、23\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='8',c,NUMTOSTR(當前月,0)+'月轉折日:*6、8、15、23\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='9',c,NUMTOSTR(當前月,0)+'月轉折日:8、15、*1 8、23\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='10',c,NUMTOSTR(當前月,0)+'月轉折日:8、15、23、*31\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='11',c,NUMTOSTR(當前月,0)+'月轉折日:8、15、23、*28\n \n   \n \n   '),COLOR00FFFF,ALIGN5;
DRAWTEXT(SYSPARAM(2)=BARPOS and NUMTOSTR(當前月,0)='12',c,NUMTOSTR(當前月,0)+'月轉折日:8、15、23、*31\n \n   \n \n   '),COLOR00FFFF,ALIGN5;


{-----------------------------立體K線--------------------------------------}
Ko:=close;
Kc:=ref(close,1);

STICKLINE(ko<=kc ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(ko<=kc ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(ko<=kc ,CLOSE ,OPEN,6,0 ),COLOR00aa00;
STICKLINE(ko<=kc ,CLOSE ,OPEN,5,0 ),COLOR00bb00;
STICKLINE(ko<=kc,CLOSE ,OPEN,4,0 ),COLOR00cc00;
STICKLINE(ko<=kc,CLOSE ,OPEN,3,0 ),COLOR33dd00;
STICKLINE(ko<=kc,CLOSE ,OPEN,2,0 ),COLOR00ee00;
STICKLINE(ko<=kc,CLOSE ,OPEN,1,0 ),COLOR66ff00;

STICKLINE(ko>kc,CLOSE,OPEN,8,0 ),COLOr000088;
STICKLINE(ko>kc,CLOSE,OPEN,7,0 ),COLOr000099;
STICKLINE(ko>kc,CLOSE,OPEN,6 ,0 ),COLOR0000aa;
STICKLINE(ko>kc,CLOSE,OPEN,5,0 ),COLOr0000bb;
STICKLINE(ko>kc,CLOSE,OPEN,4,0 ),COLOr0000cc;
STICKLINE(ko>kc,CLOSE,OPEN,3 ,0 ),COLOR0000dd;
STICKLINE(ko>kc,CLOSE,OPEN,2,0 ),COLOr0000ee;
STICKLINE(ko>kc,CLOSE,OPEN,1 ,0 ),COLOR0033ff;

STICKLINE(ko>kc,OPEN,LOW,0.5,0 ),COLORred;
STICKLINE(ko>kc,CLOSE,HIGH,0.5 ,0 ),COLORred;
STICKLINE(ko<=kc,CLOSE,LOW,0.5 ,0 ),COLOR66cc33;
STICKLINE(ko<=kc,OPEN,HIGH,0.5 ,0 ),COLOR66cc33;

pl5:=之字轉向(3,5);
en1:=之字轉向(3,5)>向前引用(之字轉向(3,5),1) and 向前引用(之字轉向(3,5),1)<=向前引用(之字轉向(3,5),2) and 向前引用(之字轉向(3,5),2)<=向前引用(之字轉向(3,5),3);
ex1:=之字轉向(3,5)<向前引用(之字轉向(3,5),1) and 向前引用(之字轉向(3,5),1)>=向前引用(之字轉向(3,5),2) and 向前引用(之字轉向(3,5),2)>=向前引用(之字轉向(3,5),3);
pl10:=之字轉向(3,13);
en2:=之字轉向(3,10)>向前引用(之字轉向(3,10),1) and 向前引用(之字轉向(3,10),1)<=向前引用(之字轉向(3,10),2) and 向前引用(之字轉向(3,10),2)<=向前引用(之字轉向(3,10),3);
ex2:=之字轉向(3,10)<向前引用(之字轉向(3,10),1) and 向前引用(之字轉向(3,10),1)>=向前引用(之字轉向(3,10),2) and 向前引用(之字轉向(3,10),2)>=向前引用(之字轉向(3,10),3);
pl20:=之字轉向(3,26);
en3:= 之字轉向(3,20)>向前引用(之字轉向(3,20),1) and 向前引用(之字轉向(3,20),1)<=向前引用(之字轉向(3,20),2) and 向前引用(之字轉向(3,20),2)<=向前引用(之字轉向(3,20),3);
ex3:=之字轉向(3,20)<向前引用(之字轉向(3,20),1) and 向前引用(之字轉向(3,20),1)>=向前引用(之字轉向(3,20),2) and 向前引用(之字轉向(3,20),2)>=向前引用(之字轉向(3,20),3);
pl40:=之字轉向(3,55);
走強1:=上一次條件成立位置(pl5<向前引用(pl5,1));
走弱1:=上一次條件成立位置(pl5>向前引用(pl5,1));
走強2:=上一次條件成立位置(pl10<向前引用(pl10,1));
走弱2:=上一次條件成立位置(pl10>向前引用(pl10,1));
走強3:=上一次條件成立位置(pl20<向前引用(pl20,1));
走弱3:=上一次條件成立位置(pl20>向前引用(pl20,1));
ztjz5:=條件函數(pl10>向前引用(pl10,1),統計總數(en1,走強2),0);
ztjd5:=條件函數(pl10>向前引用(pl10,1),統計總數(ex1,走強2),0);
dtjz5:=條件函數(pl10<向前引用(pl10,1),統計總數(en1,走弱2),0);
dtjd5:=條件函數(pl10<向前引用(pl10,1),統計總數(ex1,走弱2),0);
ztjz10:=條件函數(pl20>向前引用(pl20,1),統計總數(en2,走強3),0);
ztjd10:=條件函數(pl20>向前引用(pl20,1),統計總數(ex2,走強3),0);
dtjz10:=條件函數(pl20<向前引用(pl20,1),統計總數(en2,走弱3),0);
dtjd10:=條件函數(pl20<向前引用(pl20,1),統計總數(ex2,走弱3),0);
顯示文字(en1 and dtjz5=1,最低價*0.98,'(Ⅰ)'),colorffff00;
顯示文字(ex1 and dtjd5=2,最高價*1.02,'(Ⅱ)'),colorffff00;
顯示文字(en2 and ztjz5=1,最低價*0.98,'(Ⅲ)'),colorffff00;
顯示文字(ex1 and pl10>向前引用(pl10,1) and ztjd5=1,最高價*1.02,'⑴'),colorff;
顯示文字(en1 and pl10>向前引用(pl10,1) and ztjz5=2,最低價*0.98,'⑵'),colorff;
顯示文字(ex1 and pl10>向前引用(pl10,1) and ztjz5=2,最高價*1.02,'⑶'),colorff;
顯示文字(en1 and pl10>向前引用(pl10,1) and ztjz5=3,最低價*0.98,'⑷'),colorff;
顯示文字(ex2 and pl20>向前引用(pl20,1) and ztjd10=1,最高價*1.02,'⑸'),colorff;
顯示文字(en2 and dtjz10=1,最低價*0.94,'【A】'),color00ff00;
顯示文字(ex2 and dtjd10=2,最高價*1.03,'【B】'),color00ff00;
顯示文字(en3 and ztjz10=1,最低價*0.94,'【C】'),color00ff00;
顯示文字(ex2 and pl20>向前引用(pl20,1) and ztjd10=1,最高價*1.04,'①'),Linethick3,colorffff;
顯示文字(en2 and pl20>向前引用(pl20,1) and ztjz10=2,最低價*0.94,'②'),Linethick3,colorffff;
顯示文字(ex2 and pl20>向前引用(pl20,1) and ztjd10=2 or (ztjd10=0 or ztjd10=2) and ex2,最高價*1.04,'③'),Linethick3,colorffff;
顯示文字(en2 and pl20>向前引用(pl20,1) and ztjz10=3,最低價*0.94,'④'),Linethick3,colorffff;
DMLJ:=最高值(最高價,120);


TY:=收盤價;
HD:=信號過濾(向前賦值(信號過濾(向前引用(TY,10)=最高值(TY,2*10+1),10),10+1),10);
LD:=信號過濾(向前賦值(信號過濾(向前引用(TY,10)=最低值(TY,2*10+1),10),10+1),10);
A:=向前引用(收盤價,上一次條件成立位置(HD));
B:=向前引用(收盤價,上一次條件成立位置(LD));
T1:=上一次條件成立位置(HD)<上一次條件成立位置(LD) AND 求邏輯非(HD) ;
T2:=上一次條件成立位置(HD)>上一次條件成立位置(LD) AND 求邏輯非(LD);
波浪頂:條件函數(T1,A,A),COLORFF00FF,點狀線,LINETHICK4;
畫柱線(T1,A,A,9,0),COLORFF00FF;
波浪底:條件函數(T2,B,B),COLOR80FF00,點狀線,LINETHICK4;
VAR3:=最低值(最高價,240);
VAR4:=100*(收盤價-VAR3)/VAR3;
VAR5:=(收盤價-最低值(最低價,528))/(最高值(最高價,528)-最低值(最低價,528))*100;
VAR6:=(收盤價-最低值(收盤價,530))/(最高值(收盤價,530)-最低值(收盤價,530))*100;
VAR7:=0;
VAR8:=簡單移動平均(最高值(收盤價-向前引用(收盤價,1),0),34)/簡單移動平均(絕對值(收盤價-向前引用(收盤價,1)),7)*100;
VAR9:=簡單移動平均(最高值(收盤價-向前引用(收盤價,1),0),13)/簡單移動平均(絕對值(收盤價-向前引用(收盤價,1)),13)*100;
VARA:=有效值周期數(收盤價);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND 統計總數(VARB,1)=1;
VARD:=指數平滑移動平均(收盤價,21)-指數平滑移動平均(收盤價,8);
VARE:=指數平滑移動平均(VARD,5);
VARF:=前M個波谷值(3,6,1)<4 AND 交叉函數(VARD,VARE);
VAR10:=條件函數(前M個波谷值(3,16,1)=0 AND 最高價>最低價+0.04,4,0);
VAR11:=之字轉向(3,6)>向前引用(之字轉向(3,6),1) AND 向前引用(之字轉向(3,6),1)<=向前引用(之字轉向(3,6),2) AND 向前引用(之字轉向(3,6),2)<=向前引用(之字轉向(3,6),3);
VAR12:=之字轉向(3,6)<向前引用(之字轉向(3,6),1) AND 向前引用(之字轉向(3,6),1)>=向前引用(之字轉向(3,6),2) AND 向前引用(之字轉向(3,6),2)>=向前引用(之字轉向(3,6),3);
VAR13:=之字轉向(3,22)>向前引用(之字轉向(3,22),1) AND 向前引用(之字轉向(3,22),1)<=向前引用(之字轉向(3,22),2) AND 向前引用(之字轉向(3,22),2)<=向前引用(之字轉向(3,22),3);
VAR14:=之字轉向(3,22)<向前引用 (之字轉向(3,22),1) AND 向前引用(之字轉向(3,22),1)>=向前引用(之字轉向(3,22),2) AND 向前引用(之字轉向(3,22),2)>=向前引用(之字轉向(3,22),3);
VAR15:=之字轉向(3,51)>向前引用 (之字轉向(3,51),1) AND 向前引用(之字轉向(3,51),1)<=向前引用(之字轉向(3,51),2) AND 向前引用(之字轉向(3,51),2)<=向前引用(之字轉向(3,51),3);
VAR16:=之字轉向(3,51)<向前引用 (之字轉向(3,51),1) AND 向前引用(之字轉向(3,51),1)>=向前引用(之字轉向(3,51),2) AND 向前引用(之字轉向(3,51),2)>=向前引用(之字轉向(3,51),3);
VAR17:=之字轉向(3,72)>向前引用 (之字轉向(3,72),1) AND 向前引用(之字轉向(3,72),1)<=向前引用(之字轉向(3,72),2) AND 向前引用(之字轉向(3,72),2)<=向前引用(之字轉向(3,72),3);
VAR18:=之字轉向(3,72)<向前引用 (之字轉向(3,72),1) AND 向前引用(之字轉向(3,72),1)>=向前引用(之字轉向(3,72),2) AND 向前引用(之字轉向(3,72),2)>=向前引用(之字轉向(3,72),3);
VAR19:=指數平滑移動平均(收盤價,2)-指數平滑移動平均(收盤價,150);
VAR1A:=指數平滑移動平均(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=乘冪(VAR1B,3)*0.1+乘冪(VAR1B,1);
VAR1D:=開平方(開平方(最低價*最高價*開盤價*收盤價));
VAR1E:=指數平滑移動平均(VAR1D*0.97,3);
VAR1F:=(最高價+最低價+收盤價)/3;
VAR20:=(VAR1F-簡單移動平均(VAR1F,14))/(0.015*平均絕對偏差(VAR1F,14));
VAR21:=交叉函數(VAR1E,最低價);
買點1:=VAR10;
買點2:=(VAR11+VAR13+VAR15+VAR17);
賣點1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;
VAR22:=買點1 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);
VAR1:=簡單移動平均(收盤價,6);
VAR2:=簡單移動平均(收盤價,18);
VAR31:=簡單移動平均(收盤價,30);
VARB1:=求和(收盤價*成交量*100,28)/求和(成交量*100,28);
VARC1:=取整(VARB1*100)/100;
VARD1:=指數平滑移動平均(收盤價,5)-指數平滑移動平均(收盤價,10);
VARE1:=指數平滑移動平均(VARD1,9);
VAR131:=向前引用(VARE1,1);
VAR141:=VARE1;
VAR151:=VAR141-VAR131;
VAR161:=向前引用(VARD1,1);
VAR171:=VARD1;
VAR181:=VAR171-VAR161;
VAR191:=開盤價;
VAR1A1:=收盤價;
顯示文字(買點1>0,最低價-0.01,'▲買!'),COLORRED;
顯示文字(買點2>0,最低價-0.01,'▲要漲'),COLORYELLOW;
顯示文字(賣點1>0,最高價+0.1,'▼快賣'), COLORWHITE;


a:=有效值周期數(收盤價);
ah:=最高值(最高價,72);
al:=最低值(最低價,72);
a0:=(ah-al)/21;
b1:=最低價-a0;
顯示文字((a+0)/15=向下舍入((a+0)/15),b1-2.5*a0,'▲時窗'),COLORWHITE;

var31:=上一高點位置(之字轉向(3, 19)>向前引用(之字轉向(3,19),1)
and 向前引用(之字轉向(3,19), 1)<向前引用(之字轉向(3,19), 2),0);
畫柱線(var31=2,最低價*0.95,最低價*0.98,8,0),color0000ff;
顯示文字(var31=2,最低價*0.95,'3天'),COLORWHITE;
畫柱線(var31=4,最高價*1.05,最高價*1.02,8,0),color9966ff;
顯示文字(var31=4,最高價*1.06,'5天'),COLORWHITE;
畫柱線(var31=7,最低價*0.95,最低價*0.98,8,0),color00ffff;
顯示文字(var31=7,最低價*0.95,'8天'),COLORWHITE;
畫柱線(var31=12,最高價*1.05,最高價*1.02,8,0),colorff33ff;
顯示文字(var31=12,最高價*1.06,'13天'),COLORWHITE;
畫柱線(var31=20,最低價*0.95,最低價*0.98,8,0),color0066ff;
顯示文字(var31=20,最低價*0.95,'21天'),COLORWHITE;
畫柱線(var31=33,最高價*1.05,最高價*1.02,8,0),colorffff00;
顯示文字(var31=33,最高價*1.06,'34天'),COLORWHITE;
畫柱線(var31=54,最低價*0.95,最低價*0.98,8,0),COLORWHITE;
顯示文字(var31=54,最低價*0.95,'55天'),COLORWHITE;
畫柱線(var31=88,最高價*1.05,最高價*1.02,8,0),color00ff00;
顯示文字(var31=88,最高價*1.06,'89天'),COLORWHITE;
畫柱線(var31=143,最低價*0.95,最低價*0.98,8,0),colorccffff;
顯示文字(var31=143,最低價*0.95,'144天'),COLORWHITE;
畫柱線(var31=232 ,最高價*1.05,最高價*1.02,8,0),colorff0033;
顯示文字(var31=232,最高價*1.06,'233天'),COLORWHITE;
畫柱線(var31=376,最低價*0.95,最低價*0.98,8,0),colorff9966;
顯示文字(var31=376,最低價*0.95,'377天'),COLORWHITE;

立春:=信號過濾(月份=2 AND (日期=3  OR 日期=5 ),2);
雨水:=信號過濾(月份=2 AND (日期=18 OR 日期=20),2);
驚蟄:=信號過濾(月份=3 AND (日期=5  OR 日期=7 ),2);
春分:=信號過濾(月份=3 AND (日期=20 OR 日期=22),2);
清明:=信號過濾(月份=4 AND (日期=3  OR 日期=6 ),2);
谷雨:=信號過濾(月份=4 AND (日期=19 OR 日期=21),2);
立夏:=信號過濾(月份=5 AND (日期=6  OR 日期=8 ),2);
小滿:=信號過濾(月份=5 AND (日期=20 OR 日期=22),2);
芒種:=信號過濾(月份=6 AND (日期=5  OR 日期=7 ),2);
夏至:=信號過濾(月份=6 AND (日期=20 OR 日期=22),2);
小暑:=信號過濾(月份=7 AND (日期=6  OR 日期=8 ),2);
大署:=信號過濾(月份=7 AND (日期=22 OR 日期=24),2);
立秋:=信號過濾(月份=8 AND (日期=7  OR 日期=9 ),2);
處暑:=信號過濾(月份=8 AND (日期=22 OR 日期=24),2);
白露:=信號過濾(月份=9 AND (日期=7  OR 日期=9 ),2);
秋分:=信號過濾(月份=9 AND (日期=22 OR 日期=24),2);
寒露:=信號過濾(月份=10 AND (日期=7  OR 日期=9 ),2);
霜降:=信號過濾(月份=10 AND (日期=22 OR 日期=24),2);
立冬:=信號過濾(月份=11 AND (日期=7  OR 日期=9 ),2);
小雪:=信號過濾(月份=11 AND (日期=22 OR 日期=24),2);
大雪:=信號過濾(月份=12 AND (日期=6  OR 日期=8 ),2);
冬至:=信號過濾(月份=12 AND (日期=21 OR 日期=23),2);
小寒:=信號過濾(月份=1 AND (日期=5  OR 日期=7 ),2);
大寒:=信號過濾(月份=1 AND (日期=19 OR 日期=21),2);


顯示文字(立春,最高價*1.02,'立春'),COLORgreen,ALIGN1;
顯示文字(雨水,最高價*1.02,'雨水'),COLORgreen,ALIGN1;
顯示文字(驚蟄,最高價*1.02,'驚蟄'),COLORgreen,ALIGN1;
顯示文字(春分,最高價*1.02,'春分'),COLORgreen,ALIGN1;
顯示文字(清明,最高價*1.02,'清明'),COLORgreen,ALIGN1;
顯示文字(谷雨,最高價*1.02,'谷雨'),COLORgreen,ALIGN1;
顯示文字(立夏,最高價*1.02,'立夏'),COLORMAGENTA,ALIGN1;
顯示文字(小滿,最高價*1.02,'小滿'),COLORMAGENTA,ALIGN1;
顯示文字(芒種,最高價*1.02,'芒種'),COLORMAGENTA,ALIGN1;
顯示文字(夏至,最高價*1.02,'夏至'),COLORMAGENTA,ALIGN1;
顯示文字(小暑,最高價*1.02,'小暑'),COLORMAGENTA,ALIGN1;
顯示文字(大署,最高價*1.02,'大署'),COLORMAGENTA,ALIGN1;
顯示文字(立秋,最高價*1.02,'立秋'),COLORYELLOW,ALIGN1;
顯示文字(處暑,最高價*1.02,'處暑'),COLORYELLOW,ALIGN1;
顯示文字(白露,最高價*1.02,'白露'),COLORYELLOW,ALIGN1;
顯示文字(秋分,最高價*1.02,'秋分'),COLORYELLOW,ALIGN1;
顯示文字(寒露,最高價*1.02,'寒露'),COLORYELLOW,ALIGN1;
顯示文字(霜降,最高價*1.02,'霜降'),COLORYELLOW,ALIGN1;
顯示文字(立冬,最高價*1.02,'立冬'),COLORWHITE,ALIGN1;
顯示文字(小雪,最高價*1.02,'小雪'),COLORWHITE,ALIGN1;
顯示文字(大雪,最高價*1.02,'大雪'),COLORWHITE,ALIGN1;
顯示文字(冬至,最高價*1.02,'冬至'),COLORWHITE,ALIGN1;
顯示文字(小寒,最高價*1.02,'小寒'),COLORWHITE,ALIGN1;
顯示文字(大寒,最高價*1.02,'大寒'),COLORWHITE,ALIGN1;
GET:ZIG(3,5)COLORWHITE,LINETHICK2;

{開盤既知今天高低價}
高:=MA(REF(H,1)/REF(C,2),27)*REF(C,1);
低:=MA(REF(L,1)/REF(C,2),27)*REF(C,1);
A5:=低[SYSPARAM(1)];
RA5:=低[SYSPARAM(1)-1];
A10:=高[SYSPARAM(1)];
RA10:=高[SYSPARAM(1)-1];
jt5:=if(A5>RA5,'↑','↓');
jt10:=if(A10>RA10,'↑','↓');
SZ1:='開盤預測最高價:'+NUMTOSTR(高[SYSPARAM(1)],2)+jt10;
DRAWTEXT(BARPOS=SYSPARAM(2),c,SZ1),align4,COLORMAGENTA;
SZ:='\n \n開盤預測最低價:'+NUMTOSTR(低[SYSPARAM(1)],2)+jt5;
DRAWTEXT(BARPOS=SYSPARAM(2),c,SZ),align4,COLORGREEN;

{
波神凱線使用說明
下面對軟件使用做以下簡要說明:
    一、 常用的三種測量方法:
    1.單線體:首先我們在畫線工具欄中選用“波神規律”,在“K線圖”上找出歷史波段中最低的“單線體” (K線圖中的年、月、周、日、時、分均可),用鼠標點擊“單線體” 的最低點,并從這個“單線體” 的低點劃到其高點,松開鼠標后,就會自然在其上方產生八條虛線(測下跌行情時則相反)這八條虛線,就是分析判斷未來波段高點位置的波神凱線。
    2. 多線體;以波段最低點“單線體” 的底為中心,向上方(左右均可)延伸到行情反轉時為止,它包括“雙線體”和“多線體”(當頂或底的單線體相對過小時采用)八條波神凱線的虛線自動形成。
    3.箱體法;從相對波段的最低點開始向上,劃到一個較長平臺的頂點(左右均可)自動形成八條波神凱線的虛線。它主要用于測量較大的長期趨勢。當然也適用短線行情,如日K線、分時線等。許多時候,箱體測量得出的數據比以上測量方法更準確。
    4.影線法;有時行情遇上特殊情況,往往在一條單線體上方或下方留下一根長影線,(上影或下影線大于實體1--2倍)對這樣的特殊K線體,我們可以用該線柱的上下影線測量其下一個波段的高低點。
    二、波神K線具體使用技巧及方法:
    波神凱線的八條虛線構成了一個相對完整的循環波段,對于這個循環波段,我們經過十幾萬次的實踐驗證,結果85%左右的行情運行到虛線的一或二、三線時都會做波段性的回調(或反彈)這一現象類似波浪理論中的上升一浪;回調之后(或反彈)行情又上升到第五或第六條虛線,再做回調(或反彈)這一現象類似上升中的三浪;之后再上升至七或八虛線再做回調(或反彈)此段類似上升中的五浪。值得注意的是,這些并非是一個固定的公式,因為我們在實際操作中每次所選擇和測量的波段位置不同,所以每組虛線代表的意思也就不同,如果我們選用的波段正好是回凋二浪中的第二小浪,那么此次上升就可能到我們虛線中的一線或二、三線行情就結束了。所以在實際使用中,因為波浪理論5升3降波浪的不同,即我們所介入的波浪位置不同,那么波神凱線的1至8條虛線循環終點也就有所不同。比如:我們選用“月K 線”測量1至8條波神凱線時,其終點正好在第一線或二、三線上,KDJ技術指標也處在低部金叉位置,而我們再選用“周K線”測量時,其目標正處在第五或第六線上,而周線的KDJ技術指標正處在上升的中部,而我們再選用“日K線”測量時,其目標正處在第七或第八條線上,而它的KDJ技術指標正處在頂部高位、鈍化或背離狀態,那么“日K線”第七或第八線就是一個短期頂部,如果再加上時間之窗也符合,那么短期頂部就更加準確無疑。當然回調結束后,可能行情重新上升,這是因為“周或月K線圖”KDJ中底部金叉, 促使“日K線”一輪新的循環又重新開始了,如此以似類推周爾復始,所以我們要抓住這個規律做好上下每一個波段的操作,提高投資收益。
    三、KDJ與波神凱線配合使用的方法
   為了操作方便簡單,讓初學者容易掌握,我們從十幾種技術指標中,選用反映最快最靈敏的KDJ指標做參考指標。特別在期貨和外匯市場上,短線變化復雜波動較大,許多晚上的八點至十點左右上下波動一二百點,如掌握的好,盈利非常可觀。
KDJ 技術指標要靈活地結合波神凱線去使用。比如當KDJ上升到頂或已經鈍化、背離時(下跌則相反),而上面的波神凱線,恰好到了第一線或二、三線時,我們就應該首先平多,而不要一味非等到五、六線,甚至七、八循環線了。要爭取做好每一個上下波段,增加收益。總之要結合KDJ所處上下位置的不同,來具體判斷波神凱線那條線是波段的頂或是底。
    四、時間之窗和神奇數字的使用:
    宇宙和大自然界中,許多數字的確存在著人類無法解釋的神奇與奧妙。我們用許多相關的神奇數字,統計并驗證過世界金融市場中,幾十個不同品種中的2萬多個日期,結果78%左右的日期遇到這些神奇數字,都會發生較大的“波動”、“反轉”或形成階段性的 “頂部或底部”。下面口訣中的“三五四七和十三”即可代表“日K線圖”中的日期天數,也適用于年、月、周或分鐘線中的“K線體”的個數。“六二一來上半年”是指1—6月份每個月中的6號和21號。“下半年來八二三”是指7—12月份每個月中的8號和23號。“*字符號是關鍵”中的數是通過神奇數字計算出來的。但以上所有日期因為世界各地的時間差的區別有時會相差1至2天,所以最后的口訣為“前后不差一兩天”。例如:
    2001年6月14日就是上證指數大頂2245
    2005年6月6日是上證指數大底998點。
    2006年5月12日上海期貨銅的大頂。
    2006年8月7日世界原油(連續月)大頂77.95;
    2006年5月12日是世界黃金期貨的大頂740;
    2004年12月7日和2006年5月12日英磅/美元兩次大頂;
    2004年3月22日美國大豆歷史大頂
    2006年6月13日日本橡膠大頂324.5等等。
    所以在實際操作中,我們把神奇數字的日期,也做為一個判斷波段高低點的重要參照依據,比如:
    1、我們選用了幾種測量方法(單體、三角和箱體等)結果測量結果都重合在波神凱線上。
    2、KDJ指標在頂部或底部,甚至已發生頂底背離現象。
    3、而頂部或底部的日期也正遇上時間之窗的神奇數字,那么就可以確定此波神凱線的虛線就是該波段性的高點或低點。因為多項數據測量結果重合,準確度就會更高。這個道理,就如同測量珠穆朗瑪頂峰時,當我們選用了不同角度和遠近不同距離,測繪的數據越接近和重合某一數值時,確定其頂點的精度就越高一樣。因此我們在實際使用波神軟件時,應盡量采取多種方法配合綜合使用,以使我們得到更準確的數據,從而不斷降低風險,提高我們投資收益。通過實際操作,你可能會不斷的領悟出其中更多的奧妙或有新的創新。
}

下載地址(點擊上圖是廣告,點擊下圖進入下載地址網頁)

    波神凱線入場出場 詳細用法說明(視頻)下載

軟件評論評論內容只代表網友觀點,與本站立場無關!

   評論摘要(共 0 條,得分 0 分,平均 0 分) 查看完整評論

下載說明

* 本網發布的公式指標和股票軟件絕大部分是來源于各大論壇,例如:理想論壇,老錢莊,創幻,MACD等論壇,謝謝各位老師的原創軟件。為了達到最快的下載速度,推薦使用網際快車迅雷下載本站軟件。
* 請一定升級到最新版WinRAR3.61才能正常解壓本站提供的軟件!

本網提供的公式文件說明:
* alg格式股票公式,僅僅可以用飛狐交易師股票軟件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系統股票軟件使用,少部分可以用分析家股票軟件引入使用;
* exp格式股票公式,僅可以用大智慧經典版股票軟件引入使用;
* tnc格式股票公式,可以用通達信股票軟件引入使用;
* tni格式股票公式,僅可以用通達信新版本引入使用例如通達信v6.05以上版本,通達 信老版本不能引入;
* hxf格式股票公式,僅可以用同花順股票軟件引入使用。
以上的各種軟件都可以在本網股票軟件欄目找到并下載!

* 關于股票公式時間限制,如果在引入公式的時候,發現公式名稱欄是空白的,這時候調整電腦時間到1997年,又能出現公式名稱 ,并且能正常顯示,可能是公式使用期限已過。
* 關于公式解密收費破解FNC大智慧公式;破 解hxf同花順,daf操盤手,alg飛狐等原碼,可解密完全加密定向加密公式或延時,收費服務無意勿擾,聯系QQ984388831。

* 關于股票公式源碼編輯
本網提供的源碼,一般都可以編輯成公式,如果不明白公式的編輯,在本網就可以有資 料說明編寫過程,請搜索:教程

* 如果您發現下載鏈接錯誤,請點擊報告錯誤謝謝!
* 站內提供的所有軟件包含破解及注冊碼均是由網上搜集,若侵犯了你的版權利益,敬請來信通知我們!

關于本站 | 網站幫助 | 廣告合作 | 下載聲明 | 友情連接 | 網站地圖 |

特別聲明:本站內所有廣告其網站的一切言論與行為均與本站(分析家公式網)無關,請廣大投資者小心謹慎。
Copyright © 2003-2008 88GS.Com. All Rights Reserved .
頁面執行時間:156.25000 毫秒
網站備案信息:粵ICP備05017571號
分分彩最牛回本技巧 林芝县| 乌苏市| 云安县| 金川县| 天长市| 东乡| 内丘县| 南靖县| 永清县| 渭南市| 青龙| 桂东县| 民权县| 明水县| 砚山县| 儋州市| 津市市| 临西县| 北票市| 肥城市| 辽宁省| 滨海县| 通许县| 龙泉市| 称多县| 仙桃市| 顺平县| 顺昌县| 巫溪县| 阳山县| 沙洋县| 金溪县| 阳泉市| 鄂伦春自治旗| 静海县| 中方县| 正蓝旗| 新平|